SQL Error : 1054 Unknown column ....

Moderators: goldenarrow, MirandaD, Hanmar

Antwoord op onderwerpPlaats een reactie
 
 
CCCCorine

Berichten: 5736
Geregistreerd: 10-06-03
Woonplaats: Bunschoten-Spakenburg

SQL Error : 1054 Unknown column ....

Link naar dit bericht Geplaatst door de TopicStarter: 29-12-03 23:40

Is iemand hier handig met SQL errors in combinatie met phpBB2? Ik ben namelijk met thema's aan het knutselen. 1 thema is helemaal gelukt, maar het 2e thema krijg ik niet geinstalleerd. Dan krijg ik de volgende foutmelding nadat ik op 'installeer template' heb gedrukt:

Code
phpBB : Critical Error

Could not query database for theme info

DEBUG MODE

SQL Error : 1054 Unknown column 'naam thema' in 'where clause'


Verward

Ik heb allebei de thema's zelf gemaakt, door Subsilver aan te passen. Het eerste thema is helemaal gelukt en een helemaal op zichzelf werkend thema geworden. Nu vraag ik me af of er iets mis is met thema nummer 2 of met iets anders.

Conclusie: ben de draad kwijt, wie heeft tips?


BartVB
Eigenaar

Berichten: 36263
Geregistreerd: 08-01-01
Woonplaats: Arnhem

Link naar dit bericht Geplaatst: 30-12-03 11:41

Weet je ook in welk script en op welke regel je die foutmelding kreeg? Zoek verder even op 'naam thema' in je nieuw gemaakte theme. Is namelijk niet iets dat normaal in een theme voorkomt...

ƃuılıǝɔ ǝɥʇ uo ƃuıɔuɐp ǝɹ,ǝʍ uǝɥʍ 'ƃuılǝǝɟ ɐ ʇɐɥʍ ɥo
"Als je niets te verbergen hebt, ben je een slechte paashaas" - Loesje

CCCCorine

Berichten: 5736
Geregistreerd: 10-06-03
Woonplaats: Bunschoten-Spakenburg

Link naar dit bericht Geplaatst door de TopicStarter: 30-12-03 17:14

BartVB schreef:
Weet je ook in welk script en op welke regel je die foutmelding kreeg? Zoek verder even op 'naam thema' in je nieuw gemaakte theme. Is namelijk niet iets dat normaal in een theme voorkomt...


Hij gaf alleen de bovenstaande foutmelding, verder stond er niets bij. Na het installeren van het nieuwe thema kon ik ook niets meer met het hele administratiepaneel van het forum. Ik moest via het aan het forum gekoppelde portal het originele thema weer instellen, en toen werkte alles weer (behalve het nieuwe thema dan).

Het lijkt ook niet aan het thema te liggen, want ik heb ergens anders nog een phpBB forum geinstalleerd en daar kon ik hetzelfde thema gewoon installeren zonder problemen.

CCCCorine

Berichten: 5736
Geregistreerd: 10-06-03
Woonplaats: Bunschoten-Spakenburg

Link naar dit bericht Geplaatst door de TopicStarter: 02-01-04 10:14

Iemand nog een idee?

FatherB

Berichten: 31
Geregistreerd: 26-03-03
Woonplaats: Dordrecht

Link naar dit bericht Geplaatst: 02-01-04 23:14

hoe heb je je thema genoemd? misschien mogen er geen bijzondere tekens (zoals spaties en *&%^$#@ enz enz) erin. Ik heb nu (nog) niet uitgezocht, maar das het eerste wat me binnen schiet Knipoog

Dazed and confused Verward

CCCCorine

Berichten: 5736
Geregistreerd: 10-06-03
Woonplaats: Bunschoten-Spakenburg

Link naar dit bericht Geplaatst door de TopicStarter: 03-01-04 01:59

FatherB schreef:
hoe heb je je thema genoemd? misschien mogen er geen bijzondere tekens (zoals spaties en *&%^$#@ enz enz) erin. Ik heb nu (nog) niet uitgezocht, maar das het eerste wat me binnen schiet Knipoog


Ik heb geen bijzondere tekens gebruikt. Dat is het dus ook niet. Maar in ieder geval vast bedankt voor het meedenken!

FatherB

Berichten: 31
Geregistreerd: 26-03-03
Woonplaats: Dordrecht

Link naar dit bericht Geplaatst: 03-01-04 02:07

ik heb me hersenen ff laten kraken, maar kwam niet achter hoe het komt, lijkt een intern probleem van phpBB...
en als je probeert nieuwe thema aan te maken, en gewoon de instellingen kopieren van die oude (die het niet doet)... dat al geprobeerd?

Dazed and confused Verward

CCCCorine

Berichten: 5736
Geregistreerd: 10-06-03
Woonplaats: Bunschoten-Spakenburg

Link naar dit bericht Geplaatst door de TopicStarter: 03-01-04 23:05

FatherB schreef:
ik heb me hersenen ff laten kraken, maar kwam niet achter hoe het komt, lijkt een intern probleem van phpBB...
en als je probeert nieuwe thema aan te maken, en gewoon de instellingen kopieren van die oude (die het niet doet)... dat al geprobeerd?


Dat ga ik maar eens proberen. Wel een heel werkje, want ik geloof dat ik tegen de 60 bestanden moet aanpassen dan Ach gut


Antwoord op onderwerpPlaats een reactie

Wie is er online

Gebruikers op dit forum: CecileDV, Chasingmood, eventueel, lepolight, tessaroos, xSetjeslover en 19 bezoekers